เอกสารประกอบภาคปฏิบัติ E-commerce                                Week 7  การใช้โปรแกรม SWiSHmax   
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โดย คณาจารย์สาขาวิชาระบบสารสนเทศเพื่อการจัดการ
อ.พิมลพรรณ  อุดมพันธ์
ครั้งที่ 7
การใช้โปรแกรม SWiSHmax เพื่อทำภาพเคลื่อนไหวเบื้องต้น
วัตถุประสงค์
1. เพื่อให้ผู้เรียนสามารถเปิดโปรแกรม และรู้จักองค์ประกอบของโปรแกรม
2. เพื่อให้ผู้เรียนทราบวิธีการสร้างงานเพื่อเป็นภาพเคลื่อนไหว
3. เพื่อให้ผู้เรียนทราบวิธีการใส่ลูกเล่น (Effect) เพื่อทำภาพเคลื่อนไหว
4. เพื่อให้ผู้เรียนทราบวิธีการทำแบนเนอร์เคลื่อนไหว
5. เพื่อให้ผู้เรียนทราบวิธีการบันทึกไฟล์ 
6. เพื่อให้ผู้เรียนทราบวิธีการนำไปใช้ในโปรแกรม Dreamweaver
เนื้อหา
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1. ส่วนที่ 1 รู้จักโปรแกรมและองค์ประกอบหน้าจอ
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2. ส่วนที่ 2 การสร้างชิ้นงาน
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3. การสร้างฉากใหม่
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4. การใส่ข้อความ รูปภาพ
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5. การวาดเส้นและวาดรูปลงในชิ้นงาน
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6. การทำให้วัตถุเคลื่อนที่โดยใช้ Motion Path
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7. ส่วนที่ 3 การใส่ลูกเล่น (Effect) เบื้องต้น
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8. การบันทึกไฟล์เพื่อแก้ไขและนำไปใช้ในเว็บเพจ
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9. การ Export ชิ้นงานที่สร้างขึ้นไปใช้ในเว็บเพจ
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10. การใส่ลูกเล่น (Effect) เพิ่มเติม
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11. ส่วนที่ 4 การสร้างแบนเนอร์ (Banner)
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12. ส่วนที่ 5 การใส่ Script






17
การใช้โปรแกรม SWiSHmax เบื้องต้น
ส่วนที่ 1 รู้จักโปรแกรมและองค์ประกอบหน้าจอ

โปรแกรม SwishMAX เป็นโปรแกรมที่ใช้สร้างภาพเคลื่อนไหว สามารถสร้างชิ้นงานภาพเคลื่อนไหวของ Macromedia Flash โดยไม่จำเป็นจะต้องใช้ฟังก์ชั่นของโปรแกรม Macromedia Flash ที่ยุ่งยาก เพียงแค่ใช้เครื่องมือที่โปรแกรมมีมาให้เท่านั้น ซึ่งใช้งานได้ง่าย สามารถสร้างลูกเล่นที่ซับซ้อนด้วยตัวอักษร รูปภาพ การวาดเขียน และเสียง ซึ่งใช้เวลาไม่นาน


โปรแกรม swishMAX สามารถที่จะนำเสนองานในรูปแบบของไฟล์ Shock wave Flash (.swf) ซึ่งสามารถนำไปใช้ในการสร้างเว็บเพจได้ และ ยังสามารถแปลงเป็นไฟล์ avi ซึ่งใช้ในการตัดต่อภาพยนตร์ได้อีกด้วย
*** Swish สามารถใช้งานได้โดยไม่จำเป็นต้องติดตั้ง Macromedia Flash บนคอมพิวเตอร์

หมายเหตุ ข้อมูลเพิ่มเติมเกี่ยวกับ Swish

เว็บไซต์ http://www.swishzone.com/ เป็นเว็บไซต์ ที่ให้บริการ Software ที่สนับสนุนการผลิตสื่อ graphic animation ด้วยวิธีง่าย ๆ ที่ชื่อโปรแกรม Swish มีตั้งแต่ Swish ในเวอร์ชั่น 1.0, 1.5 และ 2.0 นอกจากโปรแกรม Swish เองแล้วยังมีโปรแกรมที่คอยช่วย อำนวยความสะดวกอื่น ๆ อีก โปรแกรมในกลุ่ม Swishzone คือ Swishmax, Swishpix, Swishvideo และ Swishstudio 
โปรแกรม Swishmax ซึ่งเป็นโปรแกรมที่ช่วยในการสร้าง animation ง่าย ๆ สามารถ Import ภาพ - เสียง พิมพ์ข้อความ และสามารถใส่ Effect และก็มี Effect ให้เลือกใช้มากกว่า 200 แบบ สำหรับผู้ที่มีพื้นฐาน การใช้โปรแกรม Macromedia Flash ก็จะพบว่าโปรแกรม Swishmax ช่วยให้การใช้งานง่ายขึ้นมาก สำหรับรูปแบบ การวางชิ้นงานก็ใช้เป็น Frame โดยที่เราสามารถกำหนดรูปแบบ Frame ต่อวินาทีได้ นอกจากนี้สำหรับผู้เชี่ยวชาญ ยังสามารถเขียน Script เพื่อกำหนดรูปแบบการทำงานเพิ่มเติมได้
สำหรับผู้ที่ชอบทำสไลด์ในรูปแบบต่าง ๆ เช่นในรูปแบบ Screen Saver, exe, Website ต้องลองใช้โปรแกรม Swishpix ซึ่งด้วยกระบวนการทำงานที่ง่าย โปรแกรมนี้จึงผลิตงานออกมาได้ด้วยวิธีการเพียง 5 ขั้นตอน คือ ขั้นการเลือกภาพและนำภาพเข้ามา ขั้นตกแต่งภาพในเบื้องต้น ขั้นการนำภาพใส่อัลบั้มที่ต้องการ ขั้นตกแต่งภาพ ในระดับสูงพร้อมกำหนดเสียงและความสัมพันธ์ต่าง ๆ และขั้น Export นอกจากนี้ ยังมีปุ่มที่ใช้ control การเลื่อน และการแสดงภาพ แถมภาพในส่วนที่ใช้เป็น Background ก็เหมือนกรอบ ภาพสติ๊กเกอร์
สำหรับโปรแกรม Swish video ก็เป็นโปรแกรมที่ช่วยให้สามารถ ควบคุมวิดีโอ โดยมีแถบ Scale ปุ่ม Play ปุ่ม Stop ปุ่ม Rewind ปุ่ม Forward ทำให้สามารถควบคุมวิดีโอได้ง่ายขึ้น และสามารถ Export เพื่อนำไปใช้งาน ร่วมกับ โปรแกรมตัวอื่น ๆ ได้อีกด้วย
โปรแกรมสุดท้ายคือ Swishstudio สำหรับ นักท่องเว็บไซต์ที่ชอบเก็บไฟล์ประเภท SWF (ไฟล์ Flash ที่แปลงสำหรับ ใช้งานแล้ว) ที่สวยๆ มาประกอบในงานของตนเอง ซึ่งสามารถเก็บมาจาก Temporary Internet Files หลังจากที่เข้าไปท่องเที่ยวใน Internet ไฟล์ใน รูปแบบ SWF จะถูกนำมาเก็บที่ Temporary Internet Files ของเราโดยอัตโนมัติ แต่สำหรับผู้ที่มีไฟล์ SWF อยู่แล้วอาจนำมาใช้กับโปรแกรมนี้ได้เลยโดย จะเรียงลำดับไฟล์ที่ต้องการใช้งานตามหมายเลขได้ทันทีรวมถึง ใส่เสียงเพิ่มได้
การ Download มาใช้งานที่ http://www.swishzone.com/index.php?area=home หรือ ที่ Homepage ของเว็บไซต์ swishzone
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รู้จักองค์ประกอบหน้าจอของโปรแกรม
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1. Standard Toolbar แถบเครื่องมือลัดที่ใช้ควบคุมคำสั่งทั่วไป
	คำสั่ง
	รายละเอียด

	Bring Forward
	เลื่อนวัตถุที่เลือกอยู่ขึ้นไป 1 ชั้น

	Bring Backward
	เลื่อนวัตถุที่เลือกอยู่ลงไป 1 ชั้น

	Bring To Front
	เลื่อนวัตถุที่เลือกอยู่ให้ไปอยู่ชั้นหน้าสุด

	Bring To Back
	เลื่อนวัตถุที่เลือกอยู่ให้ไปอยู่ล่างสุด


2. Insert Toolbar แถบเครื่องมือลัดที่ใช้ในการเรียกคำสั่งแทรก
	คำสั่ง
	รายละเอียด

	Insert Scene
	เพิ่มฉาก (Scene) 

	Insert Text
	แทรกข้อความ

	Insert Image
	แทรกรูปภาพ


3. Control Toolbar แถบเครื่องมือที่ใช้ในการควบคุมการแสดงผลของชิ้นงาน
	คำสั่ง
	รายละเอียด

	Stop
	หยุดการเล่นไฟล์

	Play
	เล่นไฟล์ทั้งหมด(ทุกฉาก)

	Play Scene
	เล่นไฟล์เฉพาะฉากที่เลือก

	Play Effect
	เล่นเฉพาะลูกเล่นที่สร้างขึ้น


4. Timeline Panel แถบแสดงเวลาซึ่งจะมีลักษณะเป็นแถบสี่เหลี่ยมผืนผ้ายาว แบ่งเป็นช่องเล็กๆหลายอันซึ่งเรียกว่า Frame โดยจะเป็นตัวบ่งบอกถึงการกระทำในแต่ละเวลา อีกทั้งยังมีปุ่มที่ใช้ในการเพิ่มลูกเล่นอีกด้วย
5. Outline Panel บริเวณซึ่งแสดงโครงร่างอันดับชั้นของวัตถุที่สร้างขึ้นในไฟล์ภาพยนตร์โดยมีลักษณะเป็นชั้นที่ซ้อนทับกันตามลำดับก่อนหลังซึ่งวัตถุที่อยู่ชั้นสูงกว่าจะอยู่ข้างหน้าของวัตถุที่อยู่ในชั้นต่ำกว่าภายใน Scene เดียวกัน
6. Layout Panel บริเวณแสดงผลของชิ้นงานไฟล์ภาพยนตร์ที่ทำซึ่งเราแก้ไขและสร้างชิ้นงานในบริเวณนี้ และยังมี Toolbox หรือกล่องเครื่องมือที่ใช้สำหรับเครื่องมือพื้นฐานทั่วไป ซึ่งรายละเอียดเครื่องมือต่างๆใน Toolbox มีดังนี้
	อุปกรณ์
	รายละเอียด

	Select
	เลือกวัตถุ

	Reshape
	เปลี่ยนแปลงรูปทรง

	Motion Path
	สร้างเส้นทางการเคลื่อนที่

	Line
	เขียนเส้นตรง

	Pencil
	เขียนเส้นเองตามที่ต้องการ

	Bezier
	เขียนเส้นโค้ง

	Rectangle/Square
	วาดรูปสี่เหลี่ยม

	Ellipse/Circle
	วาดรูปวงกลม

	Auto Shape
	วาดรูปต่างๆตามแบบที่กำหนด

	Zoom
	ย่อหรือขยายขนาดจอ

	Pan
	เลื่อนภาพ


ส่วนที่ 2 การสร้างชิ้นงาน SwishMAX เบื้องต้น
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การสร้างชิ้นงานใหม่  SwishMAX จะใช้บริเวณบริเวณ Layout Panel  เป็นหลักในการออกแบบและทดสอบผล
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สร้างชิ้นงานใหม่
การสร้างชิ้นงานใหม่ ทำได้ 2 วิธี คือ 
1. คลิ้กที่เมนู File>New
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เมื่อสร้างชิ้นงานใหม่ได้แล้ว สามารถปรับแต่งคุณสมบัติต่างๆของชิ้นงานได้ที่หน้าต่างMovie ที่ด้านข้าง ดังนี้
Background Color – สีพื้นหลัง
Width – ความกว้างของชิ้นงาน
Height – ความสูงของชิ้นงาน
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Frame Rate – เวลาที่ใช้ในการเคลื่อนที่มี  หน่วยเป็นจำนวนเฟรมต่อวินาที

การแทรกฉาก (Scene) ใหม่ลงในชิ้นงาน
การแทรกฉากใหม่ในชิ้นงาน มีวิธีการดังนี้
1. คลิ้กที่เมนู Insert>Scene หรือ คลิ้กที่ปุ่มรูปฉาก ดังภาพ
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การแทรกข้อความลงในชิ้นงาน
การแทรกข้อความลงในชิ้นงาน มีวิธีการดังนี้
1. คลิ้กที่เมนู Insert>Text หรือ คลิ้กที่ปุ่มรูปตัว T ดังภาพ
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2. พิมพ์ข้อความที่ต้องการในหน้าต่าง Text ทางด้านขวา โดยสามารถปรับรูปแบบ ขนาด สี ของตัวอักษรได้ 

3. ถ้าต้องการลบหรือแก้ไขข้อความ ทำได้โดยคลิ้กที่ช่องพิมพ์ข้อความในหน้าต่าง Text แล้วทำการแก้ไข
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การแทรกรูปภาพลงในชิ้นงาน
การแทรกรูปภาพลงในชิ้นงาน มีวิธีการดังนี้
1. คลิ้กที่เมนู Insert>Image หรือ คลิ้กที่รูป ต้นไม้ ดังภาพ
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2. เลือกภาพที่ต้องการแล้วคลิ้ก Open

3. สามารถปรับแต่งคุณสมบัติต่างๆของภาพได้ที่หน้าต่าง Shape ด้านข้าง ดังรูป
Name – ชื่อของภาพ
Line – กำหนดลักษณะเส้นขอบ
Properties – กำหนดขนาดของภาพ 
ปรับความมืด-สว่าง และความคมชัดของภาพ
การวาดเส้นและวาดรูปลงในชิ้นงาน
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  ซึ่งจะใช้ในการวาดเส้นตรง หรือ ใช้เครื่องมือ [image: image5.png]A Movie - SWiSHmax
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 ในการวาดเส้นโค้งไปมาตามใจชอบเหมือนดินสอ สำหรับวิธีการใช้งานนั้น ทำในลักษณะเดียวกัน คือ 
1. เลือกเครื่องมือ จาก ToolBox ด้านซ้ายมือ 

2. คลิ้กค้างไว้บริเวณชิ้นงานแล้วลากจนได้เส้นหรือรูปร่างที่ต้องการ
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ส่วนการวาดรูปลงในชิ้นงาน มีวิธีการดังนี้
1. เลือกเครื่องมือเป็นรูปที่ต้องการวาด จาก ToolBox ด้านซ้ายมือ (สำหรับเครื่องมือ Auto Shapes ที่เป็นรูปสี่เหลี่ยมขอบมน ให้คลิ้กข้างไว้ จะมีรูปร่างต่างๆให้เลือก)
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คลิ้กค้างไว้บริเวณชิ้นงานแล้วลากจนได้ขนาดที่ต้องการ
3. ปรับแต่งคุณสมบัติของวัตถุที่วาดขึ้นมาได้ที่หน้าต่าง Shape ด้านขวา
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Line – กำหนดลักษณะเส้นขอบ
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รูปวงกลมอยู่บน                                                             รูปวงกลมอยู่ล่าง
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การจัดลำดับของวัตถุนั้น ทำได้โดย
1. คลิ้กที่วัตถุที่ต้องการจัดลำดับ
2. คลิ้กที่ปุ่มลูกศร ขึ้น ลง บริเวณ Outline panel  เพื่อจัดลำดับ
การทำให้วัตถุเคลื่อนที่โดยใช้ Motion Path

การใช้โปรแกรม Swish ทำให้วัตถุเคลื่อนที่ทำได้อย่างง่ายดาย โดยใช้เครื่องมือ Motion Path มีวิธีการดังนี้ 
1. สร้างวัตถุที่ต้องการให้เคลื่อนที่ เช่น ข้อความ Welcome จากรูป จากนั้นคลิ้กที่วัตถุ แล้วเลือกเครื่องมือ Motion Path จาก Toolbox  เครื่องหมายแสดง mouse จะเปลี่ยนเป็นรูปเครื่องหมาย +
2. คลิ้กข้างที่บริเวณกึ่งกลางวัตถุ แล้วทำการลากเส้น เพื่อให้เป็นแนวของการเคลื่อนที่ของวัตถุ
3. ทดสอบผลที่ได้โดยคลิ้กที่ปุ่ม Play [image: image12.png]A Movie - SWiSHmax
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การใส่ Effect ให้วัตถุเพิ่มเติม

เป็นการใส่รูปแบบการเคลื่อนไหวที่ โดยโปรแกรมได้จัดเตรียมรูปแบบอัตโนมัติหลากหลาย และสวยงาม เพียงแต่เราเลือก และทดสอบดูผลจนกว่าจะพอใจ (รายละเอียดเพิ่มเติมดูในหัวข้อถัดไป)

1. คลิกเลือกวัตถุที่ต้องการ เช่น ข้อความ หรือ รูปภาพ
2. คลิกเมาส์ปุ่มขวา เมนูลัดจะแสดงให้เห็น และให้เลือก Effect / Appear  into position ดังรูป
3. ทดสอบด้วยปุ่ม Play



การบันทึกชิ้นงานที่สร้างขึ้น
การบันทึกชิ้นงานที่สร้างขึ้น ทำได้โดย 
1. คลิ้กที่ปุ่ม File>Save

2. ตั้งชื่อไฟล์ตามต้องการแล้วคลิ้กที่ปุ่ม Save

3. โปรแกรมจะขึ้นหน้าต่างถามว่า ต้องการ Export เป็นไฟล์ .swf  (เพื่อนำไปใช้ในการออกแบบเพจ) หรือไม่ ให้เลือกตามต้องการแล้วคลิ้กที่ปุ่ม OK

4. ถ้าเลือกต้องการให้ Export เป็น .swf (เลือกหัวข้อที่ 1) โปรแกรมจะขึ้นหน้าต่างเพื่อให้ตั้งชื่อไฟล์ ให้ทำการตั้งชื่อไฟล์ แล้วคลิ้ก Save

การ Export ชิ้นงานที่สร้างขึ้นไปใช้ในเว็บเพจ
โปรแกรม Swish สามารถ Export ไฟล์จาก .swi (นามสกุลของโปรแกรม Swish) ไป  เป็น .swf , .html , .exe , .avi ได้ โดยมีวิธีการดังนี้
1. เลือกเมนู File>Export 

2. เลือกชนิดของไฟล์ที่ต้องการเปลี่ยน
3. โปรแกรมจะขึ้นหน้าต่าง ให้ตั้งชื่อไฟล์ตามต้องการแล้วคลิ้กที่ปุ่ม  Save


การนำไปใช้งานในโปรแกรม Marcromedia Dreamweaver

1.  เปิดโปรแกรม Marcromedia Dreamweaver และเลือกไฟล์เว็บเพจที่ต้องการ

2.  คลิกที่เมนู Insert / media / Flash

3.  คลิกเลือกชื่อไฟล์เคลื่อนไหว Swish ที่นามสกุล .swf  ตามต้องการ ดังรูป
4.  ทดสอบโดยการกดปุ่ม F121
 

เลือก Insert/Media/Flash



ตย. ภาพหลังจากแทรกรูป
ส่วนที่ 3 การใส่ลูกเล่นให้กับชิ้นงาน (Effect)


การใช้งาน SwishMAX เพื่อสร้างงานให้มี effect(ลูกเล่น) สวยงามทำได้โดยใช้วิธีง่ายๆ  คือ ผู้ใช้งานสามารถเลือกใส่ effect ต่างๆให้กับชิ้นงานได้ effect แต่ละชนิดก็จะมีรูปแบบแตกต่างกันไป ใน SwishMAX นั้น มี effect ให้เลือกมากมาย จะขอยกมาเป็นตัวอย่าง ดังนี้ 

· Fade in เป็นลูกเล่นสำหรับแสดงวัตถุขึ้นมาอย่างช้าๆ ในตำแหน่งที่ต้องการ 
· Fade out เป็นลูกเล่นสำหรับแสดงวัตถุให้หายไปอย่างช้าๆ ในตำแหน่งที่ต้องการ
· Zoom in เป็นลูกเล่นสำหรับแสดงการขยายวัตถุ จากขนาดเล็กให้เป็นขนาดปกติ
· Zoom out เป็นลูกเล่นสำหรับแสดงการย่อวัตถุ จากขนาดใหญ่ให้เป็นขนาดปกติ
· Slide in เป็นลูกเล่นสำหรับแสดงการเคลื่อนที่ของวัตถุเป็นเส้นตรง จากหน้าจอเข้ามาสู่ภายในจอ โดยจะมีคำสั่งย่อยให้เลือกว่าต้องการให้เคลื่อนที่มาจากทางใด
· Slide out เป็นลูกเล่นสำหรับแสดงการเคลื่อนที่ของวัตถุเป็นเส้นตรง จากภายในหน้าจอ ไปสู่ภายนอก โดยจะมีคำสั่งย่อยให้เลือกว่าต้องการให้เคลื่อนที่ออกไปทางใด
· Blur เป็นลูกเล่นสำหรับแสดงผลวัตถุอย่างช้าๆ โดยเริ่มจากภาพใหญ่ที่ไม่ชัดเจน จนกลายเป็นภาพที่สมบูรณ์
· Appear into position เป็นลูกเล่นสำหรับแสดงผลวัตถุในลักษณะค่อยๆปรากฏขึ้น ซึ่งมีลักษณะการปรากฏให้เลือกอีกหลายแบบ ดังภาพ
· Disappear from position เป็นลูกเล่นสำหรับแสดงผลวัตถุในลักษณะค่อยๆหายไป ซึ่งมีลักษณะการหายจากหน้าจอให้เลือกอีกหลายแบบ ดังภาพ

การใส่ Effect ให้กับชิ้นงาน


การใส่ Effectให้กับชิ้นงาน ทำได้ดังนี้ 
1. เลือกวัตถุที่ต้องการใส่ Effect โดยการคลิ้กที่วัตถุนั้น
2. คลิ้กที่ปุ่ม Add Effect หรือ คลิกเมาส์ปุ่มขวาเข้าเมนูลัด
3. เลือก Effect ที่ต้องการ
4. ทดสอบผลที่ได้โดยคลิ้กที่ปุ่ม Play [image: image13.png]A Movie - SWiSHmax
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การปรับแต่ง Effect



การปรับแต่ง Effect ให้กับชิ้นงาน ทำได้ดังนี้ 
1. เลือกวัตถุที่ต้องการปรับแต่ง Effect โดยการคลิ้กที่วัตถุนั้น
2. ถ้าต้องการให้วัตถุเคลื่อนที่ช้าลงให้ทำการขยายขนาด Effect โดยคลิ้กค้างที่เส้นด้านท้ายของ Effect แล้วลากให้ขยายออก


3. ถ้าต้องการให้วัตถุเคลื่อนที่เร็วขึ้นให้ทำการลดขนาด Effect โดยคลิ้กค้างที่เส้นด้านท้ายของ Effect แล้วลากให้แคบลง

4. ทดสอบผลที่ได้โดยคลิ้กที่ปุ่ม Play [image: image14.png]A Movie - SWiSHmax
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การลบ Effect


การลบ Effect ทำได้ดังนี้ 
1. เลือกวัตถุที่ต้องการลบ Effect โดยการคลิ้กที่วัตถุนั้น
2. คลิ้กที่ Effect ที่ต้องการลบ บริเวณ Timeline Panel

3. กดปุ่ม Delete ที่คีย์บอร์ด
4. ทดสอบผลที่ได้โดยคลิ้กที่ปุ่ม Play [image: image15.png]A Movie - SWiSHmax
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  ที่ Tool Bar

ส่วนที่ 4  ตัวอย่างการทำแบนเนอร์  (Banner) สำหรับใช้ในเว็บไซต์

โปรแกรม Swish เป็นโปรแกรมสร้างกราฟิกอย่างง่ายๆ ซึ่งสามารถใช้ในการสร้างภาพเคลื่อนไหวเพื่อตกแต่งเว็บไซต์ได้อย่างสะดวกและรวดเร็ว 
ในส่วนนี้จะขอยกตัวอย่างการใช้โปรแกรม Swish เพื่อสร้างแบนเนอร์และนำมาใช้ในการตกแต่งเว็บไซต์

ตัวอย่างการทำแบนเนอร์
1. เปิดโปรแกรม Swish เลือก Start a new empty movie
2. ปรับขนาดของภาพดังนี้ Width = 760 Height 80 

3. ปรับสีตามต้องการที่ Background Color

4. แทรกภาพโดยคลิ้กที่ปุ่ม Insert Image แล้วเลือกภาพที่ต้องการ
5. คลิ้กที่ภาพเพื่อทำการตั้งชื่อภาพ โดยพิมพ์ชื่อในแท็บ Shape ที่ช่อง Name  (ตั้งชื่อเพื่อให้สะดวกเวลาทำงาน) สามารถคลิ้กค้างที่ภาพ และลากไปมา เพื่อวางบนจุดที่เหมาะสมได้ หรือสามารถย่อขยายภาพได้โดยคลิ้กที่ภาพ แล้วคลิ้กค้างที่รูปสี่เหลี่ยมบริเวณมุมของภาพ
6. คลิ้กที่แทรกข้อความแล้วแทรกข้อความที่ต้องการลงไป ปรับแต่งรูปแบบข้อความได้ที่แท็บ Text

7. ใส่ effect ให้รูปภาพและข้อความตามต้องการ โดยคลิ้กที่ภาพหรือข้อความนั้น แล้วคลิ้กที่ปุ่ม Add Effect 
8. ปรับความเร็ว และการเคลื่อนไหวของภาพที่ Timeline Panel


9. ทดสอบผลที่ได้โดยคลิ้กที่ปุ่ม Play [image: image16.png]A Movie - SWiSHmax
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 ที่ Tool Bar

10. เมื่อปรับแต่งจนได้ผลตามที่ต้องการแล้ว ทำการเซฟ โดยคลิ้กที่เมนู File>Save พร้อมทั้งทำการ Export เป็น .swf เพื่อจะนำไปใช้ในการสร้างเว็บ เพจต่อไป





ส่วนที่ 5 การใส่ Script เบื้องต้น

ในโปรแกรม Swish มี Script เตรียมไว้ให้มากมาย ที่มักใช้บ่อยๆ มีดังนี้
	Script
	รายละเอียด

	Movie Control>gotoAndPlay>gotoAndPlay(FRAME)
	แสดงเฟรมที่ต้องการ

	Movie Control>gotoAndPlay>nextFrameAndPlay()
	แสดงเฟรมถัดไป

	Movie Control>gotoAndPlay>prevFrameAndPlay()
	แสดงเฟรมก่อนหน้า

	Movie Control>gotoAndPlay>nextSceneAndPlay()
	แสดงฉาก (Scene) ถัดไป

	Movie Control>gotoAndPlay>prevSceneAndPlay()
	แสดงฉาก (Scene) ก่อนหน้า

	Browser/Network>getURL(…)
	ไปที่ URL

	Sound>playSound(…)
	ใส่เสียง


การใส่ Script เกี่ยวกับการควบคุมการแสดงผลชิ้นงาน




Movie Control>gotoAndPlay>nextSceneAndPlay() ใช้เมื่อแสดงฉากแรกเสร็จแล้ว ต้องการให้แสดงฉากถัดไป ทำได้โดย
1. เลือกเฟรมที่ต้องการให้เปลี่ยนฉาก เช่น เลือกเฟรมที่ 10 ดังภาพ 


2. คลิ้กที่ปุ่ม Add Script แล้วเลือก Movie Control> gotoAndPlay> nextSceneAndPlay() โปรแกรมจะทำการสลับมุมมองไปยัง Script View ดังภาพ



3. จะมีสัญลักษณ์     ขึ้นที่ Timeline Panel ในเฟรมที่ทำการเลือกไว้
4. ทดสอบผลที่ได้โดยกลับไปที่ Layout Vies แล้วคลิ้กที่ปุ่ม Play [image: image17.png]A Movie - SWiSHmax
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  ที่ Tool Bar

*** คำสั่งอื่นๆในหมวดของ  Movie Control>gotoAndPlay ก็จะทำในลักษณะเดียวกัน ***
การใส่ Script เกี่ยวกับการสร้างการเชื่อมโยง (Link) 

Browser/Network>getURL(…) ใช้เมื่อต้องการสร้างการเชื่อมโยง (Link) ไปที่ URL ต่างๆ ทำได้โดย

1. เลือกบริเวณที่ต้องการสร้างการเชื่อมโยง ถ้าต้องการให้คลิ้กบริเวณชิ้นงานทั้งหมดแล้วเชื่อมโยงไป ให้คลิ้กบริเวณที่ว่างในฉาก จะมีรูปกากบาทล้อมรอบฉาก แล้วทำการคลิ้กที่ปุ่ม Add Script และเลือก Browser/Network>getURL(…)  ดังภาพ
แต่ถ้าต้องการให้คลิ้กที่วัตถุใดวัตถุหนึ่งบนชิ้นงานแล้วจึงทำการเชื่อมโยงไป ให้คลิ้ก

ขวาที่วัตถุนั้น แล้วเลือก Script>Browser/Network>getURL(…) ดังภาพ

2. ใส่ข้อมูลตามต้องการโดย URL คือ URL ที่ต้องการให้ทำการเชื่อมโยงไปและ Window คือลักษณะในการเปิดการเชื่อมโยงนั้น (เลือกได้โดยคลิ้กที่ลูกศรชี้ลงด้านข้าง) ที่นิยมใช้มี 2 แบบคือ


_self
เปิดการเชื่อมโยงทับในหน้าเดิม

_blank
เปิดการเชื่อมโยงในหน้าใหม่


3. เมื่อใส่ข้อมูลที่ต้องการเรียบร้อยจะได้ ดังภาพ 
ทดสอบผลที่ได้โดยกลับไปที่ Layout View แล้วคลิ้กที่ปุ่ม Play [image: image18.png]A Movie - SWiSHmax
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  ที่ Tool Bar

การใส่ Script เกี่ยวกับเสียง 

Sound>playSound(…) ใช้เมื่อต้องการใส่เสียงในเฟรมหรือฉากที่ต้องการ ทำได้โดย
1. เลือกฉากหรือเฟรมที่ต้องการใส่เสียง เช่น เฟรมที่ 10 ดังภาพ

2. คลิ้กที่ Add Script เลือก Sound>playSound(…)

3. ทำการ Import ไฟล์เสียงที่ต้องการ โดยคลิ้กที่ปุ่ม Import



เลือกเสียงที่ต้องการแล้วคลิ้กที่ปุ่ม Open ไฟล์เพลงที่ทำการ Import จะขึ้นมาอยู่ใน list ด้านล่าง ดังภาพ

4. เลือกไฟล์เสียงที่ต้องการ จะแสดงแถบสีเทา และชื่อไฟล์เสียงนั้นจะแทรกอยู่ใน Script และจะมีสัญลักษณ์  ที่เฟรมที่ทำการเลือกไว้

5. ทดสอบผลที่ได้โดยคลิ้กที่ปุ่ม Play [image: image19.png]A Movie - SWiSHmax
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  ที่ Tool Bar

การลบ  Script



การลบ Script ทำได้ดังนี้ 
1. เลือกวัตถุที่ต้องการลบ Script โดยการคลิ้กที่วัตถุนั้น
2. กดปุ่ม Delete ที่คีย์บอร์ด หรือ คลิ้กที่ปุ่ม Del Script

เอกสารอ้างอิง
1. ictc.doae.go.th/html/tutorial/manual/SwishMAX.doc 

2. ศึกษาเพิ่มเติมด้วยตนเองได้ที่  http://lampang.thcity.com/flash/indexo.html

7.Layout Panel





6.Outline Panel





2.Insert Toolbar





3.Control Toolbar





5. Timeline Panel





1.Standard Toolbar





ที่ Outline Panel จะมี Scene เพิ่มขึ้น








สัญลักษณ์เส้นจุดการเคลื่อนที่ของวัตถุ





จุดเริ่มต้นของวัตถุ





จุดสิ้นสุดของวัตถุ





แสดง Timeline การเคลื่อนที่





ปุ่ม Motion Path





ชื่อ Effect ต่าง ๆ





ถ้าต้องการเปลี่ยนแปลง


เฟรมที่เลือกไว้ เช่น ต้องการให้เปลี่ยนฉากที่เฟรมที่ 12 แทน สามารถเปลี่ยนตัวเลขได้ที่ช่อง Frame �(บริเวณกรอบด้านล่าง)�แต่ถ้าไม่ต้องการเปลี่ยน คือให้เป็นเฟรมที่ 10 ที่เลือกไว้ตั้งแต่แรก ไม่ต้องเปลี่ยนแปลงใดๆ








Insert Text





Insert Image





ใส่ effect





เส้น Timeline แสดง effect





Insert Image





กำหนดขนาด Banner





เลือก object





คลิก Add object





หรือคลิกเมาส์ปุ่มขวาเข้าเมนูลัด





Media/Flash





สัญลักษณ์เมื่ออยู่บน Dream





เปลี่ยนรูปแบบ





ปุ่ม Shape
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